VoIP.ms Status Page (Beta)
This page is dedicated to providing all updates about VoIP.ms service availability and scheduled maintenances

Resolved
USA DID Numbers

Started
2023-02-14 at 19:00:35
Status
Resolved after about 2 hours

Impact

Degraded performance
Affected
Voice
Inbound Calls
  • Resolved
    2023-02-14 at 20:33:05

    Our upstream carrier was able to identify and correct an internal routing issue. All calls are connecting correctly now.

  • Investigating
    2023-02-14 at 19:00:35

    We are aware that some numbers from USA are experiencing an issue receiving calls and returning a busy signal. Our team is investigating this issue with our upstream carrier.